FEMA US&R Response Sys/U.S. Army Corps of Engineers
ADVANCED STRUCTURES SPECIALIST TRAINING

StS2- GPS V COMPUTER INTERFACE
LESSON PLAN

TIME FRAME: 60-minute Lecture

MATERIALS:

PowerPoint Slides
Overhead Computer and Projection

Equipment
References*:
A Introduction to Using a Garmin GPS with Paper
Maps for Land
Navigation, Garmin Corporation, 2003.
GPS Personal Navigator: Quick Start Guide,
Garmin Corporation, 2001-2002.
GPS Training—Garmin GPS V, Instructional
Video, Garmin Corporation, 2003.
What is WAAS: Wide Area Augmentation System,
Web Site:
http://www.garmin.com/aboutGPS/waas.html,
Garmin Corporation, 1996-2004.
MapSource: User’s Guide and Reference
Manual, Garmin Corporation, 1999-2003.
Terminal Objective:
At the conclusion of this session, the participant will be familiar
with MapSource and other mapping software programs and be
able to exchange information between a computer and the
Garmin GPS receiver.

* All reference material used courtesy of Garmin Ltd. or its
subsidiaries. All reference material copyrighted by Garmin Ltd.
or its subsidiaries.
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Enabling Objectives:
Upon completion of this unit, participants will:
•

•
•

Using mapping software, be able to:
o Establish Waypoints
o Establish Routes
o Use Map Sets
Demonstrate data transfer between the Garmin V GPS
receiver and a laptop computer
Be able to use the MapSource toolbar

Outline:
A. Computer Overview
• System Requirements
• MapSource Toolbars
B. Understanding Waypoints
• Waypoint properties
• Creating waypoints
• Waypoint tool
C. Understanding Routes
• Creating routes
• Using the Route tool
• Auto Route with the Route tool
• Route properties
D. Using Map Sets
• What is a Map Set
• Selecting regional maps
• Creating a Map Set
• Naming a Map Set
E. Describe Data Transfer
• From MapSource to GPS
• From GPS to MapSource
F. Using MapSource Toolbar
• Menu function
• File function
• Edit function
• View function
• Tools function
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INTRODUCTION
The purpose of this module is to familiarize the students with
MapSource, proprietary mapping software by Garmin that
allows users to view a wide variety of mapping programs and
exchange information between a computer and the Garmin
GPS receiver.
There are many mapping software programs available on the
market that provides a wealth of mapping information, some
highly customized. This information can be downloaded to a
GPS receiver by US&R members to increase accuracy, locate
waypoints and establish routes prior to responding to an
impact area. Information secured by Search teams can also be
uploaded after a search assignment from the GPS unit back to
a computer. Critical information, such as victim location, hot
zone and hazard areas, can be forwarded to Logistics or
Command.
However, one limitation of GPS receivers is their ability to hold
information. For example, the Garmin V is limited to 19
megabytes of information. In contrast, a laptop computer has a
much larger processor and storage capacity and can handle a
much greater degree of information.
To overcome the storage limitation of the GPS unit, a user
generally first views map information on a computer, decides
what information is important, then links the computer to the
GPS receiver and download the desired information. One links
a Garmin GPS unit to a computer using the MapSource
mapping software. The following discusses how to do that.
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Computer Overview
Minimum System Requirements
The minimum system requirement to use MapSource includes:
Computer Overview & Introduction

•
•
•
•
•
•
•

IBM-compatible PC with Pentium processor or
equivalent
16-32 Megabytes RAM
CD-ROM drive
Mouse or other pointing device
256-color display adapter (24-bit color
recommended)
Monitor resolution of 640 x 480 or higher
20 Megabytes to 1.5 Gigabytes of free hard drive
space (depending
on the map data)
MapSource also requires a 32-bit operating
system such as Windows 95/98/2000/ME/XP or
Windows NT 4.0. An available serial port or USB
port (if applicable) is required for interfacing with
a Garmin GPS unit. If a MapSource product
comes with “locked” data, one needs Internet
access to unlock the data to access the software.

Connecting the GPS UNIT to a Computer
To connect the GPS unit to a computer via a Serial Interface
Cable:
1. Using a PC Interface Cable, connect the GPS unit to
a serial communications port on the computer.
2. To ensure a good connection, MapSource automatically
detects a GPS connection to the COM port. Check that the
GPS unit is powered on and the Serial Data Format is set to
Garmin.

3. Select “Get Unit ID” from the Tools menu.
4. Click”Auto Detect.” MapSource will verify that the
GPS unit is properly connected to the computer.
5. Click “OK” to set the COM port and exit.
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Computer Overview (continued)
MapSource Toolbars

Computer Overview & Introduction

Like a standard windows environment, the MapSource screen
interface uses four toolbars: File, Edit, View, and Tools. These
toolbars also have shortcut icons that allow quicker access to
many of the MapSource features. Therefore, the File, Edit,
View, and Tools icons also appear in the Menu Bar, along with
Right-Click menus, and will receive a more thorough
description in the last section of this lesson plan.
Before using the Toolbars, a user may prefer customize the
location of the Toolbars icons around the page. To do this,
one must undock the toolbar. To do this, place the mouse
pointer over an open area on the toolbar, click and hold the left
mouse button, and move the toolbar to a different location. To
return a toolbar to its starting location, move it back to the top
of the application.
The screen interface also includes Data tabs, Graphic Map,
Status Bar. Each of these will be described below.
File—Use these features to create a New Document,

Open a Document, Save the Current Document, and
Print the Graphic Map. One can also transfer data
between MapSource and a GPS unit or a storage card
by selecting Open From (Device), or Save To (Device).
Edit—Use these editing features to Cut, Copy, and Paste

in MapSource, Delete selected items, and Undo the last
user action. After an Undo is performed, the Redo
button is activated, allowing one to revert to the last user
action, or Redo the Undo.
User’s Interface
View—Use these features for viewing maps. One can
select a Product to view, Zoom In/Out, select a specific
Zoom Scale, or activate the Find features.
The Find feature allows one to search for a city and
view it on the Graphic Map. Some MapSource products
include the Find Places feature, allowing one to search
for a city, point of interest, or an address and view it on
the Graphic Map.
User’s Interface
StS2-GPS V-3

Pg 5

Toolbars and drop down lists

FEMA US&R Response Sys/U.S. Army Corps of Engineers
ADVANCED STRUCTURES SPECIALIST TRAINING

09/04

StS2- GPS V COMPUTER INTERFACE
MapSource Toolbars (continued)
Tool—Use these features to search for locations and

plan routes. Directly select the Zoom, Hand, Selection,
Waypoint, Route, Map, and Distance/Bearing tools.
Computer Overview & Introduction

Graphic Map—The Graphic Map displays the area of the

world that is currently selected from the MapSource
product. One can zoom in and out and move to different
parts of the selected area. At large zoom scales (ZOOM
OUT), less detail is displayed. At smaller zoom scales
(ZOOM IN), one can see the actual detailed map
features that can be transferred to the GPS unit. When
this occurs, “GPS Map Detail” is displayed below the
zoom scale in the lower right-hand corner of the Graphic
Map.
One can pan the Graphic Map in many ways: by using
the on-screen scroll bars, the keyboard’s arrow keys, or
the “Hand” tool. In addition, the Page Up and Page
Down keys move the map window up or down by the
length of the window. Hold the Ctrl key and press an
arrow key to move the map by the width of the window in
that direction (up, down, left, or right).

Moving Around the Graphic Maps—Before selecting map

sets or creating waypoints and/or routes, one must first
learn how to move around the Graphic Map.
Use any of the following methods to quickly reach a
desired destination on the Graphic Map.
• Use the Hand tool. The mouse cursor changes
to a hand over the graphic map. Press and hold
the left mouse button and move the mouse in the
direction desired on the map.
• Use the scroll bars on the right-hand side and at
the bottom of the map.
• Use the Up, Down, Left, and Right arrow keys
on the keyboard. Hold the Ctrl button down while
pressing a directional key to move a full screen in
length.
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MapSource Toolbars (continued)
To ZOOM IN and OUT of the map:

• Press the ZOOM IN or ZOOM OUT buttons on
the View toolbar.
• Select the Zoom tool from the Tools menu or
press the z button on the keyboard to active the
zoom. Click the left mouse button once on the
map to ZOOM IN and right click once to ZOOM
OUT. Click and hold the left mouse button and
drag the mouse to create a box over the desired
area.
• Use the Zoom Scale menu on the View toolbar
to zoom straight to the desired level.
• Press the Plus (+) or Minus (-) keys on the
number pad of the keyboard.
Status Bar—The Status Bar extends across the bottom of

the MapSource window. The Status Bar displays
information relating to the current action. The Status Bar
can show:
• The number of tab items selected in the tab list.
• The current Position Format and Map Datum set
in Preferences.
• Latitude and Longitude of the mouse pointer
when the mouse is positioned on the Graphic
Map, regardless of which tool is selected.
• The name and approximate data size of the
geographical map boundary currently highlighted
on the Graphic Map is displayed (if using the Map
tool).
• The distance and bearing from a beginning point is
displayed (if using the Distance/Bearing tool).
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UNDERSTANDING Waypoints
A waypoint is a geographic location stored in memory.
Waypoints can be created in MapSource using the Waypoint
tool or the “Waypoint Properties” dialog box. When a waypoint
is created, MapSource automatically assigns a name to the
waypoint based on its location. If a waypoint is created on a
map feature, the waypoint name will be an abbreviation of the
name of the feature. If the waypoint is created on an open
location, MapSource will assign a numeric name to the
waypoint. All waypoint properties can be changed, allowing
one to customize the waypoint for display and use.
Creating a Waypoint with the Waypoint Tool
The Waypoint tool can be selected three ways: by choosing
“Waypoint” in the Tools menu, by clicking on the Waypoint tool
icon in the Tools toolbar, or by using the keyboard shortcut, w.
Using Ctrl+w creates a waypoint in the center of the map and
the “Waypoint Properties” window automatically appears.
When the Waypoint tool is selected, a flag similar to the
Waypoint tool icon will appear beside the mouse pointer on the
Graphic Map.
Creating a Waypoint on the Graphic Map—To create a
Waypoint on the Graphic Map:
1. With the Waypoint tool selected, position the mouse
pointer at a location on the Graphic Map.
2. Click the left mouse button, or click the right mouse
button and select “New Waypoint.” In either case, the
“Waypoint Properties” dialog box appears.
3. Make any desired changes to the “Waypoint Properties,”
then click “OK” to save the new waypoint or click
“Cancel” to exit the dialog box.
When a Waypoint is created on the Graphic Map, the
“Waypoint Properties” dialog box is displayed. To accept the
new waypoint as is, click “OK.” To reject the waypoint click
“Cancel.”
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Creating A Waypoint with the Waypoint Properties
A waypoint can also be created based on the center of the
Graphic Map display by using the Waypoint Properties. To
create a Waypoint with the Waypoint Properties:
1. Select “New Waypoint” from the Edit menu. This
displays the “Waypoint Properties” dialog box.
MapSource assigns a name and location based on
the center of the Graphic Map.
2. Make any desired changes to the “Waypoint
Properties,” then click “OK” to save the new
waypoint. To reject the waypoint, click “Cancel.”
Waypoint Cautions
When changing the name or description, remember that
Garmin GPS products can only display a limited number of
characters. The name or description is truncated in the GPS
Unit if it exceeds the unit’s limit. If multiple waypoints have
identical names after truncation, only one of the waypoints will
be stored in the GPS Unit. Refer to the GPS Owner’s manual
to determine the GPS unit’s limitations.
All MapSource waypoints can contain proximity information. If
the GPS unit is capable of using proximity waypoints and new
waypoints that contain a proximity range are saved to the GPS
unit, then all waypoints in the GPS unit’s proximity list will be
deleted and replaced with the new MapSource waypoints.

If the symbol selected does not exist in the GPS unit, the
waypoint will be represented by a square when transferred to
the GPS unit.
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Editing Waypoints
Most editing features for waypoints can be performed in the
“Waypoint Properties” dialog box. To activate the “Waypoint
Properties,” do one of the following:
• Double-click a waypoint name in the Waypoints tab list
• Double-click a waypoint on the Graphic Map
• Highlight a waypoint in the Waypoints tab list or on the
Graphic Map, and then select “Waypoint Properties
“from the Edit menu
• Highlight a waypoint in the Waypoints tab list or on the
Graphic Map, then click the right mouse button and
select “Waypoint Properties”
Understanding Waypoints
Waypoint Properties

Waypoint Properties
Nine properties can be modified for the selected waypoint:
Name, Description, Position, Altitude, Proximity, Depth,
Symbol, Color, and Display. The waypoint can also be entered
on the Graphic Map by clicking “Show on Map.”
Name— Most Garmin GPS systems limit the name to six

characters. If the length of the name exceeds the
limitations of the unit, the name is truncated when
transferred.
Description— Enter a description to help identify the

waypoint. Garmin GPS units have a maximum number of
characters allowed in the description field. If the
description that is entered exceeds the unit limitation,
the description is truncated. Refer to the GPS unit’s
Owner’s manual to determine the GPS unit’s limitations.
Position— The coordinates of the waypoint are displayed

in the “Position” field. The coordinates are displayed
according to the Position Format set up in Preferences.
Enter new coordinates to change the position of the
waypoint.
Altitude— If known, enter an altitude for the waypoint.
Proximity— Enter a range for a proximity warning.
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Waypoint Properties (continued)
Depth— Enter a depth for underwater waypoints. This is
only compatible with GPS/Sounder combination units.
Symbol—Allows one to choose from over 100 different

symbols. If a symbol is selected that is not supported by
the GPS system, it will be represented with a square
symbol.
Color—This property allows the user to select from 16

colors for the waypoint. This property does not apply to
all Garmin GPS systems. Refer to the GPS Owner’s
manual to determine if the GPS unit is capable of
displaying waypoint colors.
Display— Allows one to choose how the waypoint will be

displayed, selecting from one of three settings: Symbol
only, Symbol and Name, or Symbol and Description.
Show On Map— Enters the waypoint on the Graphic Map

while keeping the “Waypoint Properties” window open.
This action also centers the new waypoint on the
Graphic Map.
UNDERSTANDING Routes
One can create a route in MapSource by using the Route tool
on the Tools bar, or by using the “Route Properties” dialog box.
Using CitySelect, one can create a direct route (a straight-line
route or “as the crow flies”), or an automatic route (turn-byturn). Note:
Understanding Routes

Using the Route Tool

Route
Tool

The Route tool can be selected in several ways: by choosing
Route from the Tools menu, by clicking the Route tool icon in
the Tools toolbar, and by using the keyboard shortcut, Ctrl+r.
One can also start a route by clicking the right mouse button
on the desired starting point on the Graphic Map and then
selecting Begin Route. To create a direct route with the Route
Tool:
1. After selecting the Route tool, click the waypoints or map
locations in the sequence they are wanted to appear in the
route. If a waypoint does not exist where one clicks on the
map, a new waypoint will be created at that location. As one
continues, route legs are created in a direct line from one
point to the next.
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Using the Route Tool (continued)
2. When all of the points that are wanted in the route are
entered, press Esc on the keyboard or right-click the last
point on the route and select “Cancel.” The route is
created and automatically named using the first and last
names of the waypoints.
To create an automatic route with the Route Tool:
1. Follow directions in the previous section: “To create a
direct route with the Route Tool.”
2. Using CitySelect, MapSource automatically calculates a
turn-by turn route. The auto-route is displayed on the
Graphic Map along the roads it follows, instead of
showing a direct line from one point to the next. Detailed
information about an auto-route’s turns can be viewed in
the “Directions” tab in “Route Properties.”
Using the Route Properties
One can create a route with the Route Properties by inserting
waypoints and, with some MapSource products, by inserting
points of interest, cities, or addresses through the Find feature.
Start a new route with the Route Properties by selecting New
Route in the Edit menu (or by using Ctrl + r). This will open the
“Route Properties” dialog box.
To create a direct route (straight line) with the Route
Properties:
1. With the “Route Properties” dialog box displayed,
click “Find.”
2. Under the Waypoint tab, type in the name of the waypoint
desired, or click “Select” to display the “Select Waypoint”
dialog box. The waypoint or a list of waypoints appears.

3. Highlight and double-click the waypoint that is
desired, then click “Find” again to search. The waypoint
appears in the “Places” box in the Waypoint tab.
4. Highlight the new waypoint and click “Add to Route”
to add the waypoint to the route. If enabled, one can
also use “Find” to search for a city or point of interest to
add to the route. The route points or “Via Points” are
listed in “Route Properties” as they are added to the
route.
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Using the Route Properties (continued)
5. Repeat steps 1-4 to add Via Points to the end of the
route. When finished, click “OK” to save the new route.
To create an automatic route with the Route Properties:
1. Follow the previous directions: “To create a direct route
with the Route Properties.”
2. Using CitySelect, MapSource automatically calculates a
turn-by-turn route. As points are added, the directions
and turns are listed between each waypoint in the
“Directions” tab of the “Route Properties” dialog box.
The automatic route displays the roads it follows on the
Graphic Map instead of showing a direct line from one
point to the next.
To add a map location to an automatic route with the Route
Properties:
1. Under the “Via Points” tab, select a point in the route
where a map location is wanted. To add a map location
at the end of the route, highlight the blank space at the
end of the route list. To add a point anywhere else, click
the Via Point in the list that follows the location added.
2. Click “Find.” The “Find Places” dialog box appears,
allowing one to search, if applicable, for a city, point of
interest, address, or waypoint to add to the route.
3. When the desired map location is found, click “Find”
to add it to the “Places” list.
4. Click “Add to Route” in the advanced “Find Places”
dialog box. The map location is added directly before
the point selected in the route.
5. Click “OK.” MapSource automatically calculates the
new location into the route.
Reference

StS2-GPS V-3

Pg 13

09/04

FEMA US&R Response Sys/U.S. Army Corps of Engineers
ADVANCED STRUCTURES SPECIALIST TRAINING

StS2- GPS V COMPUTER INTERFACE
Naming a Route
If the “Autoname” checkbox is marked, MapSource
automatically names the route using the names of the first and
last waypoints entered in the route. To enter a different name,
remove the mark from the “Autoname” checkbox in the “Route
Properties” window and enter a name in the “Name” field.
Inverting a Route
One can reverse the order of the route waypoints by clicking
“Invert.” This feature is convenient when one wants to navigate
a route in the reverse direction. When finished, click “OK” to
save the route.
Viewing and Printing Directions of an Auto-Route (Turn-byTurn)
Using CitySelect, one has the opportunity to view and print the
directions of the auto-route created. After selecting the
“Directions” tab in the Route Properties, the information
displayed is “Directions/Name,” “Distance,” “Leg Length,” and
“Leg Time.” Click “Print Directions” to send the turn-by-turn
directions to a printer.
Editing Routes
Routes can be edited on the Graphic Map using the Selection
tool in one of three ways. Choose the Selection tool by clicking
the Selection tool icon from the Tools toolbar, choose
“Selection” from the Tools menu, or use the keyboard shortcut,
Ctrl+s. The Selection tool allows one to add waypoints to the
beginning, middle, or end of a route; to remove a waypoint
from a route; and to move a waypoint to a new location in a
route. Note: when using a routable product, the “Route
Properties” dialog box shows directions and turns from one
waypoint to the next in the selected route. It also allows one to
print the directions to a local printer.
Reference
Inserting Waypoints—To insert a waypoint in an existing
route:
1. With the Selection tool activated, select the route in
the Routes tab list or on the Graphic Map by clicking
on it with the left mouse button. When the route is
selected, it is highlighted in yellow.
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Inserting Waypoints (continued)

2. Click the left mouse button on the route leg
desired, or click the right mouse button on the
route leg and select “Insert Route Section.” The
mouse pointer now has the “plus sign” (+) and a
small icon of the Route tool below it. The route
leg will “rubber band,” allowing one to stretch it to
an existing waypoint or a map location.
3. Place the mouse pointer at the desired
position, click the right mouse button and select
“Add to Route,” or click the left mouse button to
add the point to the route leg.
4. Repeat these steps to insert additional
waypoints. Click the left mouse button away from
the route or press the Esc key on the keyboard to
quit and save the changes to the route.
Extend a Route—To extend a route (adding a waypoint to
the beginning or end of a route):

1. With the Selection tool activated, select the route in
the Routes tab list or on the Graphic Map by clicking
on it with the left mouse button. When the route is
selected, it is displayed in yellow.

2. Left-click the first or last waypoint in the route,
or right-click the first or last waypoint in the route
and select “Resume Route.” The mouse pointer
will now have the “plus sign” (+) and a small icon
of the Route tool below it.
3. Move the extension line to an existing waypoint
or a map location. Click the right mouse button
and select Add to Route, or click the left mouse
button to anchor the route leg.
4. Repeat these steps to add more waypoints.
Click the right mouse button and select Cancel,
or press the Esc key on the keyboard to quit and
save the changes to the route.
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Remove a Waypoint—To remove a waypoint from a route:

1a. With the mouse pointer located on the route
waypoint desired, click the right mouse button and
select “Remove Waypoint From Route.”

Or:
1b. Click the left mouse button on the waypoint
(highlighted in yellow). Select “Remove Waypoint
From Route” from the Edit menu.
Move a Waypoint—To move a waypoint to another
location in a route:
1. With the Selection tool activated, select the
route in the Routes tab list or on the Graphic
Map by clicking on it with the left mouse
button. When the route is selected, it is
highlighted in yellow.

2. Left-click the waypoint desiring to move, or
right-click the waypoint and select “Replace
Route Section.” The mouse pointer will now
have a curved arrow and a small icon of the
Waypoint tool below it. The route leg will
“rubber band,” allowing one to move the
waypoint to a new location.
3. Position the mouse pointer where desired,
hen click the right mouse button and select “
Add to Route,” or click the left mouse button to
move the waypoint.
Editing Routes with the Route Properties
Many editing functions for routes can be performed in the
“Route Properties” dialog box.
Edit a Route –To edit a Route with the Route Properties:
1. Select the route in the Routes tab list or on the
Graphic Map.
2. Choose “Route Properties” from the Edit menu, or
click the right mouse button and select “Route
Properties.”
3. Make the desired changes and click “OK” to save the
changes and exit.
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Editing Route Terminology
The following terminology is used when editing a route.
Name— To change the route name, make sure the

Autoname checkbox is not marked and type in a new
name.
Center Map on Selected Item— With this box checked,

when a Via Point is selected in the route, it is
automatically centered on the map while viewing the
“Route Properties.”
OK— Select this button to save changes to the route and

exit the “Route Properties” window.
Cancel— Select this button to cancel any changes made

to the route and exit the “Route Properties” window.
Cut/Copy/Paste/Delete/Undo/Redo— Editing buttons that

also appear in the Edit menu. These options let the user
cut, copy, paste, and delete Via Points in the current
route. One can also undo and redo these editing
actions. These options can be used for the following
purpose:
• To move one Via Point from its current location
to another location within the route. One can also
use the yellow up and down arrows to the left to
adjust the Via Point up or down one level.
• To remove a Via Point from the current route.
• To undo the last action. The Redo option is
available after an Undo action. This option is
simply “Redo the Undo.”
Via Point Properties— Select the waypoint in the route list

and click “Via Point Properties.” The “Via Point
Properties” for the selected waypoint appears, allowing
one to review and edit the waypoint.
Find— This button allows one to search for a city, point

of interest (if applicable), address (if applicable), or
another waypoint to add to the route.
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Editing Route Terminology (continued)
Recalculate— In the Autorouting Preferences in the Edit

menu has been modified, one may recalculate an
existing route according to the new preferences by
clicking “Recalculate.” One may also use the
“Recalculate” to change a direct route into an automatic
route.
Invert— Reverses the waypoint order, making the last

waypoint become the first waypoint in the route.
Show On Map— Centers the map on the selected route.

Deleting a Route
One can delete a route on the Graphic Map or in the Routes
tab list. To delete a route:
1. With the Selection tool activated, select the desired
route in the Routes tab list or on the Graphic Map by
clicking on it with the left mouse button. When the route
is selected, it is highlighted in yellow.
2a. Press the Delete key on the keyboard; select Delete
Route from the Edit menu; click the right mouse button
on the highlighted route either on the Graphic Map or in
the Routes tab list and select Delete Route.
Or…
2b. Click “Delete” in the Edit toolbar. Deleting a route
from the Route Tab.
Using Map Sets

Using Map Sets

What is a Map Set?

Selecting regional maps

A Garmin unit provides very detailed information for a given
area, but is limited in its storage capacity. Therefore, the user
needs to limit the amount of mapping information downloaded
from a software program to the Garmin unit. To do this, the
user selects a desired map area for downloading. However,
the desired map area may encompass more than one “regional
map.” When this happens, the software program will “select”
and combine regional maps into “map sets” which cover the
area chosen by the user.
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Selecting Regional Maps
One can select maps from more than one MapSource data
source, however, if these maps “overlap”, they will not appear
at the same time on the GPS unit because it is only possible to
see data from one data source. When this occurs, it is
necessary to turn the overlapping map off in order to see the
other map underneath. (Refer to the GPS Owner’s Manual to
see how to turn MapSource downloaded maps on or off.)
As an example, if one selects both “Topographical” and “Roads
& Recreational” data for the same geographical area, only the
Roads and Recreational data will display. The unit WILL NOT
display a combination of topographic and road data. Therefore,
to see the Topographical data, turn the Roads & Recreational
data off.
After selecting map sets from the Graphic Map, the names of
the maps are placed in a list form under the Maps data tab on
the left side of the screen. One can view the name of the map
area, what MapSource program the map comes from, and how
much memory it requires for download.
Using the Map Tool—To Select Areas Using the Map Tool:

1. Select a Zoom Scale to view the boundaries of the
desired area map (most can be seen at the 30 mile/50
km zoom scale).

2. Choose “Map” from the Tools menu. When the
Map tool is located within a detailed map, the
borders of the area are outlined in yellow and the
map name/memory requirement will be displayed
in the Status Bar. The MapSource data loaded
determines the geographical map boundaries;
note that each product has different boundary
areas.
Add a Map—To add a map to the Map Set:

1. Click the left mouse button in the selected area. To
choose several maps, click and drag the mouse to
draw a box through the different areas on the Graphic
Map. As maps are added, they are shaded in pink. The
number of maps and the memory required to store
the maps is displayed at the bottom of the Maps tab
on the left of the screen.

At the bottom of the Maps tab list, the number of selected maps
and the required memory for the Map Set are displayed.
StS2-GPS V-3
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Remove a Map—To remove a map from the Map Set/Maps

Tab List:
1a. Place the Map tool inside the border of the
region to deselect and click the left mouse button.
To remove several maps at once, hold the Ctrl
key and click and drag the mouse to draw a box
through the regions on the Graphic Map.
Or…
1b. Highlight the desired regional map in the
Maps tab list. To select several maps, hold down
the Shift key on the keyboard and highlight the
desired maps. Click the right mouse button and
select “Delete Map,” or select “Delete Map” from
the Edit menu, or press the Delete key on the
keyboard.
Using CitySelect, check the “Include route calculation data” box
located at the bottom of the Maps tab list.

Using Map Sets
Creating a Map Set
Naming a Map Set

Naming/Renaming a Map Set
MapSource automatically names a Map Set when it is created.
If one wants to name or rename a map, go to the Maps tab list.
At the bottom of the tab, click “Map Set Name” and enter a new
name in the “Name” field. Click “OK.”
Map Properties
The name, type of coverage area, and size of the map can be
viewed in the “Map Properties” window by doing one of the
following:
• Double-click the map name in the Maps tab list
• Highlight the map name and press Enter
• Right-click the map name and select “Map Properties”
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Transferring Data
Map sets, waypoints, and routes can be transferred in two
ways: from the MapSource program to a Garmin GPS unit or
storage card using the Save To command, or from a Garmin
GPS unit or storage card to the MapSource program using the
Open From command. Data is transferred in a variety of
methods, as shown in the general list below.

When a Garmin GPS unit connects to a computer, the maps,
waypoints and routes can be transferred from MapSource
(Save To) to a Garmin GPS unit and vice versa (Open From).
Data Transfer from MapSource to the GPS Unit
Before transferring data from MapSource to the GPS unit, in
the “Serial Connection Settings” dialog box, one can modify the
communication settings by selecting a different Port or Baud
Rate, or have MapSource automatically detect the Port and
Baud Rate of the connection by clicking “Auto Detect.”
If transferring maps from MapSource to a GPS unit Select
“Open From” in the File menu and choose the device type. In
the “What To Open” dialog box, select the data type for
transfer by placing a check mark in the box (es) next to the
type of data desired to open, or click “Select All.”
Under these settings, one can also choose to “Turn Off GPS
After Transfer” by placing a check mark in the box. Click “Save”
to begin data transfer. As the transfer takes place, MapSource
displays a progress indicator and the GPS unit displays a
message indicating that the data is transferring.
Data Transfer from a GPS Unit to MapSource:
Before transferring data by Serial GPS to MapSource, in the
“Serial Connection Settings” dialog box, one can modify the
communication settings by selecting a different Port or Baud
Rate, or have MapSource automatically detect the Port and
Baud Rate of the connection by clicking “Auto Detect.”
Under these settings, one can also choose to “Turn Off GPS
After Transfer” by placing a check mark in the box. Click
“Open” to begin data transfer. As the transfer takes place,
MapSource displays a progress indicator and the GPS unit
displays a message indicating that the data is transferring.
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MapSource Toolbar Menu
As previously mentioned, the MapSource screen interface uses
four toolbars: File, Edit, View, and Tools. This section
describes in greater detail how these same functions work
using shortcut icons that allow quicker access to many of the
MapSource features. These icons appear under the Menu Bar,
along with Right-Click menus.
File Menu
This feature is used to create a New Document, Open a
Document, Save the Current Document, and Print the Graphic
Map. One can also transfer data between MapSource and a
GPS unit. The File Menu has the following commands:
New— Opens a new MapSource document that contains
empty data tabs.

Edit Function

Open— Opens a previously saved MapSource

document.
Save/Save As— Saves the current MapSource document.
Print— Prints the current Graphic Map display.
Print Preview— Shows a preview of what will be printed.

To print the preview, click the “Print” button that appears
on the preview page.
Print Setup— Activates the setup page for printing the

MapSource Graphic Map display.
Open From— Transfers selected data (Maps, Waypoints,

Routes, and Tracks) from a GPS unit.
Save To— Transfers selected MapSource data to a GPS

unit.
User’s Interface
Send Mail— Sends an e-mail with the current MapSource

document as an attachment. The recipient must own a
MapSource program and the version must be equal to or
greater than the version of the file sent.
Import— Opens data stored using Garmin’s PCX5

Version 2.09 software. MapSource displays waypoints
(.wpt), routes (.rte), or one of the maps (.grm) provided
with PCX5.
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File Menu (continued)
Export— Allows the user to export MapSource data in a

tab-delimited text format (.txt)--for use in a word
processor or spreadsheet--or in a .dxf format.
Recent Files— Shows the four most recently used

MapSource documents.
To quickly reopen one of these files, click the document
name.
Exit—

Closes the MapSource application.

Edit Menu
Use these editing features to Cut, Copy, and Paste in
MapSource, Delete selected items, and Undo the last user
action. After an Undo is performed, the Redo button is
activated, allowing one to revert to the last user action, or
Redo the Undo.
Undo— Reverts to the most recent previous action taken
by the user.
Redo— After an Undo action is performed, the Redo

button is activated, allowing one to revert to the last user
action, or Redo the Undo.
Cut, Copy, Paste— These functions work like many other

Windows programs to cut or copy any MapSource list
information in the Data tabs to the Windows clipboard
for the following purposes:
• To paste data from one active MapSource
document to another
active MapSource document.
• To paste MapSource information into a word
processor, simple text editor, or a spreadsheet
program in tab-delimited text format.
New Waypoint— Automatically creates a new waypoint in

the center of the Graphic Map, assigns a waypoint
name, description, and displays the “Waypoint
Properties” dialog box. One can change the waypoint
name, description, and/or position as well as assign an
altitude, enter a proximity distance, enter a depth,
choose a symbol, select display colors and set the
display options for the waypoint.
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New Waypoint (continued)

1. To center the waypoint on the Graphic Map,
click “Show on Map.”
2. When finished, click “OK” to save or “Cancel”
to remove the waypoint. For more detailed
information, see “Creating Waypoints” in the
Reference section of this manual.
New Route— Displays the “Route Properties” dialog box.

To create a new route:

MapSource Toolbar Reference Functions
Edit Function

1. Click the “Find” button. In the “Find Places”
window under the Waypoint tab, select a
waypoint by typing the name of the waypoint, or
select from a list of waypoints by clicking the
“Select” button (The waypoints must have already
been created and saved waypoints to choose
from a list).
2. After selecting the waypoint, click “Find” to
locate the waypoint. Click Add to Route” to add
the waypoint to the route. With some MapSource
products, one can search for a city, point of
interest, or an address to add to the route by
clicking the appropriate tab button (City, Feature,
or Address). Continue inserting route points in
the order to create the route desired. When the
last point has been inserted, click“OK” to save
and add the new route to the Routes tab list.
3. To view the new route on the Graphic Map,
click “Show on Map.” When a route is created,
MapSource automatically assigns a name based
on the names of first and last route waypoints. To
change the route name, uncheck the “Autoname”
box. This will activate the name field so one can
type in a new route name.
Duplicate Route— Duplicates the selected route in the

route list. The name of the new, duplicated route is
followed by a numerical value to indicate duplication.
Delete Item— Deletes Waypoint(s), Route(s), or Map(s)

selected in the tab list or on the Graphic Map.
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Edit Menu (continued)
Remove Waypoint(s) from Route— Removes a selected

waypoint from the selected route.
Properties— Activates the “Map,” “Route,” or “Waypoint,”

dialog box, depending on the data item that is selected.
Select All— Highlights all data in the active tab list and

on the Graphic
Edit Menu: Preferences
Use this section to change the original (default) preferences
that will apply each time a MapSource product is used. Click
“Apply” when any of the Preferences settings are changed to
see the immediate effect, or click “OK” to apply the changes
and exit. (Note: if one leaves all preferences at their original
settings, Map Source will still function correctly for general
use.)
Display Tab—Use the slider control to adjust the amount
of detail that will be displayed on the Graphic Map (this
setting does not affect the amount of detail transferred
to the GPS unit) as well as options for displaying
“Services,” “Spot Soundings” (for Blue Chart users), and
“Light Sectors” (for Blue Chart users) on the Graphic
Map. To change the font of the labels on the map, click
“Change Map Font.”
Distance/Speed: Select Metric, Nautical, or Statute.
All distance or speed measurements will reflect
this setting.
Heading: Choose one of the following

• True—Displays true North headings.
• Automatic Magnetic Variation—
Automatically calculates the magnetic
variation for the geographical area.
• User—Allows user to enter a magnetic
variation.
• Grid—Provides a true North heading as
determined by the Position Format.
• Cardinal Direction—Displays the heading
and/or course as N (orth), S, (outh), E
(ast), and W (est). (Course information is
found in the Data tab section under
Routes.)
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Display Tab (continued)
Altitude/Elevation: Select Feet or Meters.
Depth: Select Feet, Meters, or Fathoms.
Area: Select Acres, Hectares, Square Feet,

Square Miles, Square Meters, or Square
Kilometers.
Position Tab—Select from the available default grid

formats or manually enter information for a user-defined
grid.
Grid: Select a grid format from the drop-down list.
Datum: Select from over 100 available map

datums—allowing MapSource to easily match up
with just about any paper chart or map--or
manually enter information for a user-defined
map datum.
File Location Tab—Allows user to set up a default location

on their computer for saving and opening MapSource
files, importing PCX5 data, and exporting .txt and .dxf
data. Manually enter the location or click “Browse” to
select the folder for the default file location.
User’s Interface
Waypoint Tab—Sets up the preferences for creating
waypoints in MapSource.
Characters: Use the drop-down menu or manually

enter a number to limit the number of characters
in waypoint names.
Creating a Waypoint on a Map Feature: To use your

own settings, check the “Use the choices above,”
option. Otherwise, MapSource can use its default
settings.
Time Tab—Sets up displayed time either by the

computer’s local time zone or by entering a Universal
Time Conversion (UTC) offset.
Find Tab—Allows user to set the maximum number of

places MapSource should find during a search as well
as how many “Recently Found” places one desires to
hold in MapSource memory.
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Edit Menu: Preferences (continued)
Routing Tab—To set up preferences for automatic routing
calculations, select or deselect the autorouting option.
This option enables or disables the automatic
calculation of turn-by-turn directions for a destination
when establishing a route.
Select, deselect, or set up the following for MapSource
to automatically calculate a route. (Note: These
features only apply to routable MapSource products. For
more information, see “Creating Routes” in the
Reference section of this manual.)
•
•
•
•
•
•

Calculation Style (Faster Time/Shorter
Distance)
Type of Vehicle
Avoid Highways
Avoid Toll Roads
Avoid U-Turns
Average Driving Speeds

View Menu
MapSource Toolbar Reference Functions

As previously mentioned, these features are used for viewing
maps. One can select a Product to view, Zoom In/Out, select a
specific Zoom Scale, or activate the Find features. The Find
features allow one to search for a city and view it on the
Graphic Map. Some MapSource products include the Find
Places feature, allowing one to search for a city, point of
interest, or an address and view it on the Graphic Map.
Show Selected Item on Map— When Waypoints or Routes
or Map are selected in the tab list, selecting this feature
displays the selected item in the center of the Graphic
Map. The menu heading changes to reflect the item(s)
selected in the tab list. For example, if a waypoint is
selected in the Waypoints tab list, the menu will read
“Show Selected Waypoint on Map.”
Go To Position— Enters a latitude/longitude position to

view on the Graphic Map.
Zoom In— Decreases the zoom scale, showing a smaller

area in more detail.
Zoom Out— Increases the zoom scale, showing a larger

area in less detail.
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View Menu (continued)
Zoom In Max— Decreases the zoom scale to the smallest

setting, showing the most detail.
Zoom Out Region— Increases the zoom scale to center

on the region that is currently selected.
GPS Map Detail— Shows the actual map information that

will be loaded into the GPS unit. Unchecking this option
will enable faster map drawing.
Show Crosshair—Re-draws the map display to show a

center point on the Graphic Map. A check mark next to
this feature in the View menu indicates that it is
selected.
Products— If more than one MapSource product has

been purchased, select a MapSource product to display
on the Graphic Map. Any coverage area on the Graphic
Map from any MapSource product can be selected if it
has been installed on the computer and is unlocked (if
required). For some MapSource products a message
will prompt the user to insert the proper CD if one
selects an area to be installed but the corresponding CD
is not in the computer’s CD-ROM drive.
Zoom Scale— Quickly selects a zoom scale from a list.
Toolbars— One can individually select/deselect the File,

Edit, View, and Tools toolbars to be shown or hidden on
the PC screen. A check mark next to the toolbar name
indicates those currently selected. One can also “Hide
All” or “Show All” toolbars.
Status Bar— Allows one to show or hide the Status Bar at

the bottom of the MapSource window. When this menu
item is checked, the Status Bar is displayed.
Find Places— Allows one to search for a city, feature

(point of interest), address or street, or a waypoint and
view it on the Graphic Map. MapSource products
include a “Find Places” dialog box with additional
criteria to help narrow the search. The number of
choices to search is determined by which MapSource
product used. With MapSource products that are
installed by region, “Find Places” only locates items
within the regions installed.
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View Menu (continued)
Find Nearest Places— Allows one to find the nearest

features relative to the center position of the map. Rightclick on any location, feature, or waypoint (including
waypoints in the Waypoint tab list), to search for the
nearest features relative to that specific position on the
map.
Recently Found Places— Allows one to select places

recently found from the initial search.
To find a City with the “Find Places” feature and view it
on the Graphic Map:
1. Select “Find Places” from the View menu. The
“Find Places” dialog box appears.
2. Under the City tab, enter a city name in the
“City” field (information can be entered in the
other fields to narrow the search). If unsure of the
city name, click the “Select” button to the right of
the “City” field to show a list of city “matches.”
Highlight the desired city and click “Select City.”
3. With the desired city name entered in the “City”
field, click “Find” to show a list of city/state matches
in the search results list. The first match is displayed
in the center of the Graphic Map and is highlighted in
the search results list.

4. Highlight the desired city and click “OK” to
keep the selected city centered on the Graphic
Map. To return to the previous map display, click
“Cancel.” To make this city a waypoint, click
“Make Waypoint.” In the Waypoint Properties
menu, click “OK” to accept the city as a waypoint.
(Note: Only cities in the selected region are
listed. For example, if the selected region is
Hawaii, cities in the continental U.S. will not be
listed.)
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To find a Feature/Point of Interest (POI), with the “Find
Places” feature:
1. Select “Find Places” from the View menu. The
“Find Places” dialog box appears.
2. In the Feature tab, use the drop-down list in
“Place Category” and, if necessary, a “Place
Subcategory.”
3. Enter the name of a Point of Interest in the
“Name” field. If desired, click the “Select” button
next to the “Name” field to select from a list of
matches for that name to help narrow the search.
To narrow the search, use the “Place Category.”
If the category that this feature is located is
unknown, keep “All Points of Interest” selected.
4. Enter the city, state, or both and then click”
Find.” All possible Point of Interest items will
appear in the “Places” section at the bottom of
the “Find Place” dialog box.
5. Highlight the desired Point of Interest.
6. To view the address and telephone number of
the Point of Interest, click “Properties” (this can
be helpful in distinguishing multiple Points of
Interest with the same name). Click “OK” to exit
the “Properties” window. To make this feature a
waypoint, click “Make Waypoint.” In the Waypoint
Properties menu, click “OK” to accept the city as
a waypoint.
7. To keep the selected point displayed in the
center of the screen, click “OK.” To return to the
previous map display, click “Cancel.” (Note: If
using a MapSource product with unlocked data,
the “Find Places” feature only locates points of
interest within the unlocked region, but it will
locate cities both within and outside the region.)
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To find an Address or Street with the “Find Places”
feature:
1. Select “Find Places” from the View menu. The
“Find Places” dialog box appears.
2. Under the Address tab, enter the number of the
address in the “Number” field.
3. Click “Select” in the “Street” field and enter the
primary street name. A list of street name “matches”
appears to narrow the search. Highlight the desired
street name from the list and click “Select Street.”

4. The full address (or the street name) appears
in the “Street” field. Enter the city, state, or both
and then click “Find.” One or more numerous
addresses will appear in the search results list.
The first match will be displayed in the center of
the Graphic Map and it will be highlighted in the
search results list.
5. Highlight the desired location to view it on the
map. If “No items found” appears, try using
another matched street name from the “Street”
field.
6. To return to the previous map display, click
“Cancel.” Select “OK” to exit the advanced “Find
Places” window and keep the map centered on
the highlighted address or street. To make this
address a waypoint, click “Make Waypoint. “ In
the Waypoint Properties menu, click “OK” to
accept the address as a waypoint.
To find a Waypoint with the “Find Places” feature:
1. Select “Find Places” from the View menu. The
“Find Places” dialog box appears.
2. Under the Waypoint tab, type the name of the
waypoint desired in the “Name” field. If the name
of the waypoint is unknown, press the “Select”
button to the right and choose the waypoint from
the available list. Click “Select Waypoint” to
select the highlighted waypoint and then click
“Find.”
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To find a Waypoint with the “Find Places” feature:
3. The first matching location is centered on the
Graphic Map and highlighted under “Places.”
Highlight the desired location to view it on the
map.
4. To return to the previous map display, click
“Cancel” or select “OK” to exit the advanced “Find
Places” window and keep the map centered on
the highlighted waypoint.
Tools Menu
These features are used to search for locations and plan
routes. Directly select the Zoom, Hand, Selection, Waypoint,
Route, Map, and Distance/Bearing tools. The tools available in
the Tools menu can be accessed through toolbar shortcuts or
keyboard shortcuts. To activate a tool, click the shortcut on the
toolbar or enter the shortcut on the keyboard (Note: When
using the single letter keyboard shortcut, the graphic map must
be selected in order to see the tool on the mouse cursor. One
can also toggle between the data tabs panel and the graphic
map panel by using the F6 key on the keyboard.)
Zoom Tool— Enables one to quickly zoom to a specific

area on the Graphic Map. The Zoom Scale feature can
be changed by clicking the ZOOM IN or ZOOM OUT
buttons, or by using the drop-down Zoom Scale list, all
located in the View toolbar, or pressing the “+” and “-”
keys on the keyboard also allows one to ZOOM IN and
OUT.
In addition, holding the Ctrl key while clicking the left
mouse button will center the Graphic Map without
changing the zoom level.
To ZOOM IN on the Graphic Map:
1. With the Zoom tool selected, click the left
mouse button to ZOOM IN by one level and recenter the Graphic Map on that point.
2. To ZOOM IN on a defined area, click and hold the
left mouse key and draw a box around the area.

StS2-GPS V-3

Pg 32

MapSource Toolbar Reference Functions
Tools Function

FEMA US&R Response Sys/U.S. Army Corps of Engineers
ADVANCED STRUCTURES SPECIALIST TRAINING

09/04

StS2- GPS V COMPUTER INTERFACE
To ZOOM OUT on the Graphic Map:
1. With the Zoom tool selected, click the right mouse
button to decrease the zoom scale by one step.
Hand Tool— Allows one to quickly pan around the

Graphic Map.
To pan around the Graphic Map:
1. Place the Handtool on the Graphic Map, click
and hold the left mouse button, and drag the
hand around the Graphic Map to view different
areas. Release the mouse button to view the
area. One can also use the Arrow Keys (Up,
Down, Left, Right) on the keyboard as a shortcut
to pan the Graphic Map in the desired direction.
User’s Interface
Selection Tool— Allows one to select map features,
waypoints, routes and tracks directly on the Graphic
Map.
To select an item on the Graphic Map:
1. Place the Selection tool on the desired item.
The item becomes highlighted in white and the
name of the item is displayed in a white box. To
view details about a map feature, click the right
mouse button on the item and select “Feature
Properties” from the options menu.
2. To select a waypoint or route for editing, click
the left mouse button on the item. The route or
waypoint is highlighted in yellow and can be
edited.
Waypoint Tool— Allows one to quickly create waypoints

on the Graphic Map. For detailed information on
creating waypoints using the Waypoint tool, see
“Creating Waypoints” in the Reference section of the
MapSource manual.
Route Tool— Allows one to quickly create or use existing

waypoints on the Graphic Map to determine a route. For
detailed information on creating routes using the Route
tool, see “Creating Routes” in the Reference section of
the MapSource manual.
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Tools Menu (continued)
Map Tool— Allows one to select maps to be added to

and removed from the Map Set. For more information,
see “Creating and Using Map Sets” in the Reference
section of the MapSource manual.
Distance/Bearing Tool— Allows one to measure the

distance and bearing from one point to another on the
Graphic Map. When using the Distance/Bearing tool,
the distance and bearing from a beginning point to the
cursor will be displayed in the Status Bar at the bottom
of the MapSource application window.
To determine a distance and bearing:
1a. Place the Distance/Bearing tool at a
“beginning” point on the Graphic Map and click
the left mouse button.
Or..
1b. With any tool selected (except the Zoom tool),
place the cursor at a “beginning” point on the Graphic
Map, click the right mouse button and select “Begin
Measurement.”

2. Move the tool/cursor to an “end” point and click
the left mouse button. The distance and bearing
from the starting point to the finishing point is
displayed in the Status Bar.
3. Continue to another “end” point, or click the
right mouse button to end the operation. Select
“Cancel” to stop measuring and keep the
measurement displayed on the Graphic Map.
Select “Clear Measurement“to stop measuring
and clear the measurement from the Graphic
Map.
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StS2- GPS V COMPUTER INTERFACE
Tools Menu (continued)
Unlock Regions— Activates the Unlock Regions window,

where one can:

MapSource Toolbar Reference Functions
Tools Function

•
•
•

View a list of unlocked map data
Add, delete, and view the unlock code
properties
Backup and restore unlock codes

If map data is unlocked during installation, the unlock
code will show in the list. If one chooses not to unlock
maps during installation or wants to unlock another
MapSource region, or wants to unlock maps for a
second Garmin GPS unit, use the “Unlock Regions”
window. See “Unlocking Maps” in the Getting Started
section of the MapSource manual.
Get Unit ID— Retrieves the Unit ID from the GPS unit.

Select either Serial Port or USB GPS. Click “OK” to get
the Unit ID. Make sure the GPS unit is connected to an
available serial communication port or USB port on a
computer. Check communication settings if error
message “The GPS is not responding” appears.
Set PC Clock— Allows one to synchronize the clock on

the computer with the GPS clock. Click “OK” to set the
PC Clock. Make sure the GPS unit is connected to a
serial communication port or a USB port (if applicable)
on a computer. Check the Connection Settings if the
error message “The GPS is not responding” appears.
Review Enabling Objectives
•
•
•
•
•
•
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Computer Overview &Introduction
Understanding Waypoints
Understanding Routes
Using Map Sets
Describe data transfer
Using Mapsource Toolbar Reference

